MySQL数据库远程访问权限设置
对于初学者小伙伴来说,我们安装
mysql
到本地服务,再用一些图形化工具链接。
一般情况下我们都能链接成功;但是、在模拟真实的环境中我们的数据库不可能直接安装在本地机器上,大多数是在云服务器上,这种情况我们的mysql也不是路边大巴招手即停的,你还是要约的(先买票!);也就是你的帐号不允许从远程登陆,只能在localhost登录,怎么办?
让我们先登录上mysql
改表(当然我们要先知道表在哪,适用于整个数据库)
#显示所有数据库
#使用mysql数据库
#找到这个user表
#查看该表所有信息
我们能清楚的对应的主机;用户以及用户权限
1、直接修改
2、加指定用户以及指定权限
新增成功,但是没有权限。
MySQL(Linux)
MySQL 9.6.0是面向Linux平台的2026年创新版本,核心架构迎来重大革新。其将外键约束与级联操作从InnoDB引擎层上移至SQL层,确保所有数据变更均被完整记录至Binlog,彻底解决了CDC(变更数据捕获)与主从复制中的数据不一致难题。此外,该版本引入container_aware启动选项以原生适配容器环境,并对审计日志进行了组件化重构,为追求极致数据一致性与云原生体验的开发者提供了全新选择。
下载
授权
直接授权(mysql8.0版本会报错,语法分割)
直接授权(改-针对新版本)
指定授权
针对mysql8.0版本以上操作时会报错无法链接;
8.0版本因为密码规则和语法规则的改变,所以要再次设置
在相同情况下依次执行以下语句
show databases;use mysql;show tables;select * from user;update user set host = '%' where user = 'root';#更新root用户的主机访问为任何值insert into user(host,user) values('ip','user');#添加一个用户user地址ip的无权限用户(可以插入新增用户信息时,附带把权限也查进去,执行时会有告警,因为表中有约束,不用深究)grant all privileges on *.* to 'user'@'ip' identified by '123456';#授权给主机为ip的user用户开放,所有数据库及对应表的所有权限,并且密码设置为123456(快速简洁)create user ‘user'@‘ip' identified by ‘123456';#创建一个主机地址是ip登录密码是123456的user用户
grant all privileges on *.* to 'user'@'ip';#链接上一步,给他所有权限create user ‘mysql'@‘%' identified by ‘123456';#创建一个主机地址可以时任何地址的登录密码是123456的mysql用户(随时随地,在任何地方的进行登录操作)
grant select,create on myemployees.* to 'mysql'@'%';#设置mysql用户只用myemployees库的查,创建权限flush privilege;#刷新下数据权限alter user ‘mysql'@‘%' identified by ‘123456' passwore expire never;#修改加密规则
alter user ‘mysql'@‘%' identified by ‘123456' mysql_native_password by '123456';#再次重置密码
flush privilege;#刷新下数据权限