目录报错场景解决思路解决方法报错场景我搭建的wordpress,上传主题无法上传,报错413
解决思路报错413是因为Nginx对上传大小做了限制(Nginx默认限制上传大小为1MB),所以我们需要通过修改配置文件的方式来去除这个限制,或者说是提高这个限制标准。
解决方法将client_max_body_size 20m;放在http{}下面[root@localhost ~]#vim /etc/nginx/nginx.conf http {include /etc/nginx/mime.types;default_type application/octet-stream;client_max_body_size 20m;}[root@localhost ~]#systemctl restart nginx发现没有报413,但是提示上传大小超过定义值,这我们就好解决了
经过find搜索,发现php.ini在/etc下[root@localhost ~]#vim /etc/php.ini upload_max_filesize = 2M修改成upload_max_filesize = 200M[root@localhost ~]#systemctl restart php-fpm.service #重启服务注意:如果用了代理服务器,代理服务器的配置文件也需要修改!
到此这篇关于Nginx部署项目上传文件报错413的解决方法的文章就介绍到这了,更多相关Nginx 报错413内容请搜索脚本之家以前的文章或继续浏览下面的相关文章希望大家以后多多支持脚本之家!
您可能感兴趣的文章:NGINX报错413 Request Entity Too Large的问题解决NGINX 报错 413 Request Entity Too Large的问题解决
