跳转到主内容
趣航编程网 - 趣学编程,启航技术之路!

关于WBlog博客程序的更新及BUG修复

首先感谢那些在使用wblog过程中发现问题并提出问题以及建议的朋友!

下面是对WBlog的更新及修复

7、2013.01.29修复了权限节点不能修改和角色授权的问题

6、2013.01.29修复了安装时表单验证问题

ThinkPHP 8.1.0 ThinkPHP 8.1.0 正式发布,深度优化路由与验证机制,完美兼容 PHP 8.4。本版本修复了数组路由配置异常,新增枚举值校验与高级数组验证功能,支持路由分类默认处理。作为高性能 PHP 框架的最新迭代,它延续了简洁实用的设计原则,提供更稳定的底层架构与更流畅的开发体验,助力开发者快速构建现代化 Web 应用与企业级系统。

下载

5、

WBlog3.1升级到WBlog3.12啦WBlog3.12使用了thinkphp

3.12的核心并且在WBlog3.1的基础上作了大量改进。

之前的WBlog3.1版本只是粗糙地完功能,代码比较松散,好多thinkphp的特性都没有用上。而WBlog3.12则使用了thinkphp的一些特性对功能和代码进行了优化,从而使WBlog的功能更加完善,注重代码的重用性和简洁性,使得代码更加规范。

4、对前台的代码及模板作了优化,修正了前后台模板路径错误问题,对前台代码引入了视图模型查询,简化了代码,提高了效率。源码已重新上传。2012.11.30 3、节点管理里点击添加节点时提示:“页面错误!请稍后再试~”!!!

导致的原因是路径不对:

错误:WBlog/admin.php?s=/Node/add正确:WBlog/admin.php?s=/Node/insert 2、后台管理提示“操作失败!密码错误!”多次重新安装“install”还是不行了登陆录限制比较严格,20>=密码>=6字符,用户名>=2字符检验员查一下.有什么问题欢迎留言.

1、较早下载的WBlog程序,可能会出现前台无法浏,导致的原因是安装程序中少了一个wb_bloginfo表,现已修正。

相关文章