navicat连接mysql时出现2003(10060)错误
原因:是由于防火墙未关闭。
解决该问题有两种方法:
1.关闭防火墙
navicat for mysql 破解版
优秀的mysql数据库远程管理工具
下载
2.设置防火墙开放端口
相关推荐:《
Navicat for mysql使用图文教程
》
第一种方法:
第二种方法:
//停止
systemctl stop firewalld.service
//禁止开机启动
systemctl disable firewalld.service//这里发现防火墙是开启的,再来查看防火墙控制的端口
systemctl status firewalld
//查看防火墙控制的端口,发现我想要监听的8081端口没有开启
firewall-cmd --list-all
//永久开启3306端口
sudo firewall-cmd --zone=public --add-port=3306/tcp --permanent
//重载防火墙
sudo firewall-cmd --reload